In some situations, the iPhone prompts the user to enter the password for the CardDAV account, even though this was previously stored manually or via MDM.
Possible causes
- The CardDAV profile may have been created manually on the iOS device as a test and was later added as an Intune policy recipient. In this case, the local settings conflict with the settings received via Intune.
- An incorrect CardDAV password may have been used on the device. The trigger may well be another CardDAV account. This can happen regardless of distribution via an MDM system or manually created accounts.
- A CardDAV account may have been deleted. When deleting CardDAV accounts, iOS may also reset the passwords of other CardDAV accounts.
- The description of the CardDAV account may have been changed after deployment.
- It is possible that a (manual or automatic) iOS upgrade caused iOS to request the CardDAV password from the user again.
Meanwhile excluded causes
Based on intensive tests, these causes have so far been technically excluded:
- The sync.blue® CardDAV server cannot be reached.
- The iOS device has been restarted.
- The DNS name of the sync.blue® CardDAV server cannot be resolved.
- The iOS device has no Internet connection.
Solutions
Time horizon | Solution | Instructions | Consideration |
Short term | Reassign MDM policy |
|
✅ Can be implemented quickly ℹ️ May need to be used more often |
Short term | Password notification | Tell users the password to enter upon request. |
✅ Quick implementable ℹ️ Support effort |
Medium term | Synchronization with personal Exchange mailboxes |
Instead of the CardDAV account in iOS, the same source contacts are synchronized into the Exchange Online mailboxes of the respective users (or into a subfolder therein). The Exchange accounts can then be set up manually or via MDM on the respective iOS devices and used as a contact source. To do this, create a new connection in the sync.blue® dashboard and select e.g. "Microsoft 365 - Exchange Online (Personal Contacts) [Multiple users via app registration and group]" as the sync target. Follow the further instructions during setup. |
✅ Permanent solution ℹ️ Requires one Exchange Online license per user
|
Long term | sync.blue® app for iOS (in planning) | Instead of the CardDAV account in iOS, the sync.blue® app for iOS is installed via MDM automatically into |
ℹ️ Not yet available ℹ️ Requires iOS 18+ ℹ️ Requires user interaction (allow access to device contacts) |
We are available for further advice at any time.
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